Using ZIETrans preferences

You can use ZIETrans preferences to control the appearance and behavior of ZIETrans Toolkit. These preferences make ZIETrans Toolkit more accessible or simplify programming tasks. To work with ZIETrans preferences, click Window > Preferences and select ZIETrans in the tree view. For quick help on any preference, place your cursor on it and press F1.

You can modify these preferences:
Hide file extensions for known file types
By default, the ZIETrans Projects view does not display common file extensions such as .jsp. For example, all the files in the Templates folder have the .jsp extension. Clear this check box if you want the ZIETrans Projects view to display all file extensions.
Show ZIETrans tips
ZIETrans tips provide helpful suggestions for new users. If you do not want to see ZIETrans tips as you use ZIETrans Toolkit, clear this check box.
Show migration warning
You can decide whether ZIETrans should display a migration warning when it finds projects which have yet to be migrated to ZIETrans V1.0 projects.
Prompt to display terminal window
You can decide whether ZIETrans should display a dialog asking you if you want to turn on the display terminal when you test your project using Debug on Server (for Web projects). This can also be turned off by selecting the check box on the dialog when it pops up.
Show extract hidden fields warning
You can decide whether ZIETrans should display a dialog warning you when it encounters a hidden field on a captured screen when one of the following events occurs:
  • Extracting data during the recording of a macro using a live terminal
  • Creating screen customization criteria using a captured screen
  • Adding a new Extract global variable action using a captured screen
Show incompatible JRE warning
If ZIETrans detects an incompatible JRE, it can warn you with a message. Select this box to display a warning dialog that the current JRE is incompatible with ZIETrans. You must change the JRE manually. Clear this box to suppress the warning dialog.
Selection filters
This list of check boxes enables you to select which types of files you want displayed in the ZIETrans Projects view. For example, if you never work with common images or style sheets, you can clear that check box and they will not appear in the ZIETrans Projects view. If you have novice users and you do not want them to work with macros or Java™ source files, you can clear those check boxes and those files will not be displayed.
Host terminal Preferences
Prompt for all macro prompts before debugging a macro
If selected, a dialog will appear when you first debug your macro, and will allow you to enter values for all prompts at once. If not selected, you will be prompted with a dialog that requests only the value for the current prompt that your macro is stepping through. You will have to enter a value for every prompt, one-by-one. This preference is only used when debugging a macro, it has no effect when playing your macro in ZIETrans Toolkit or when running of your macro or ZIETrans application.
Show macro prompt/extract name warning
Select this box if you want ZIETrans to warn you when you have entered a macro prompt or extract name that is not valid for use with Integration Objects.
Fixed font size
This preference is designed for users with impaired vision. You can specify that the size of the text on the host terminal should not change when the window is expanded or contracted. For example, if you require large type, you can set a large fixed font size and use the scroll bars to view different parts of the host terminal screen.
Screen capture highlighting colors
Colors are used to identify input fields, protected fields, hidden fields, and screen regions that match patterns. Use these preferences to change the colors that are used for these purposes.
There are more preferences which govern other behaviors related to ZIETrans. To use these preferences, expand ZIETrans in the preferences tree and click one of the sub categories:
Accessibility
Alert recognition errors with audible alarm
Select this box to play an audible alert (beep) when there is a recognition error, for example, on the Subfile component settings page. This is useful if the developer must be alerted to use screen reader software to read the message area.
BMS Import
These settings are only used when BMS source files are added to the Maps folder within the ZIETrans project without using the BMS Import wizard.
Host code page
The code page used for the BMS maps being imported.
BMS file code page
The code page used for the BMS file when it was transferred to the workstation.
Default Java Packages
Use this panel to configure default Java package names for ZIETrans artifacts that are Java source files (business logic, custom widgets, custom components, and RESTful services). A package name makes up the first part of a fully qualified Java class name (for example, for the Java class name com.myCompany.MyClass, the package name is com.myCompany)

When a package name is created for a new artifact, the name of the project is substituted for {project name}. Formatting on this substitution occurs to ensure a valid package name is created (for example, spaces are converted to underscores).

Host Simulation
TCP/IP Port Range
During trace recording and playback, ZIETrans host simulation function uses a range of ports to record or playback host communication with the host terminal or your ZIETrans application. A range of ports is used to allow trace recording and playback on multiple sessions concurrently. Use these fields to set the range of ports. The default starting port in the range is 7021, and the default ending port is 7050.
Time Delay Settings
Delay
Use the options in this drop-down to set the time delay for host simulation to wait during playback before responding to requests from the host terminal or your ZIETrans application. Options are No Delay (host simulation responds with the next screen immediately), Random (host simulation waits a random delay, within defined minimum and maximum times, before responding) , and Actual (host simulation waits the amount of time it actually took the screen to appear during recording). The default is No Delay. If you select Random, use the Minimum and Maximum fields to set delay value ranges.
Minimum (ms)
If the Delay setting is Random, use this field to set the minimum delay in milliseconds that host simulation will wait before responding with the next screen during playback.
Maximum
If the Delay setting is Random, use this field to set the maximum delay in milliseconds that host simulation will wait before responding with the next screen during playback.
Integration Object
Automatically generate Integration Object when saving macro
Select this check box if you want an Integration Object to be generated each time you save a macro. Clear the check box if you prefer to create Integration Objects manually. See Using Integration Objects for information about creating Integration Objects from macros.
Automatically generate EJB Access Bean in ZIETrans EJB Project when an Integration Object is created
Select this check box if you want an EJB Access Bean to be generated in your ZIETrans EJB Project whenever you create an Integration Object. If you have selected the Automatically generate Integration Object when saving macro preference, an EJB Access Bean will be created along with the Integration Object when you create or modify a macro.
Template to be used for Integration Object generation
If you create new Integration Object templates, as described in the ZIETrans Web Application Programmer's Guide, use this preference to specify the template to be used when you create Integration Object file.
Template to be used for Integration Object BeanInfo generation
If you create new Integration Object templates, as described in the ZIETrans Web Application Programmer's Guide, use this preference to specify the template to be used when defining an Integration Object BeanInfo file.
Transformation
These preferences are used when you create a new blank transformation.
Include a Free Layout Table (Web only)
When you create a blank transformation, the default height and width of the table is retrieved from this setting. By default, this setting is initialized to 100% unless you specify something different. You can also specify measurements in pixels by selecting Pixels from the drop-down menu.
Note: If a host component is inserted after the table in the transformation, the rendered component will not be displayed when run on server because the table uses 100% of the screen
Except when the project is optimized for mobile devices
Select this preference to prevent including a free layout table in new blank transformations in projects that are optimized for mobile devices.
Open the Properties view after inserting a host component
Select this box to open the Properties view after inserting a host component in a transformation.
Visual Macro Editor
Show screen actions by default
Select this preference to show actions on macro screen objects by default. Clear this preference to hide the actions by default. You can click the action toggle on the macro screen to show/hide the actions for the specific screen. This preference only affects macros opened in the Visual Macro Editor for the first time. The default is selected.
Restrict number of screen actions shown
Specifies the maximum number of actions displayed for a macro screen object. This is useful for complex macros where the interface is too complex if all actions are shown. The default is 5.

When you modify your ZIETrans preferences, you can click Apply to see the results immediately in ZIETrans Toolkit. Click OK to save your new preferences and close the Preferences window, or Cancel to exit without saving. If you click Cancel, only those changes you have made since you clicked Apply are cancelled.

You can return your ZIETrans preferences to their initial values by clicking Restore defaults.

If you configure your ZIETrans preferences on one ZIETrans Toolkit, and you want to copy them to other development workstations, from the Rational® SDP menu bar select File > Export > General > Preferences to save your preferences as an .epf file. Transfer the file to each workstation where you want to use it, or make it available over your network. Select File > Import > General > Preferences to import the preferences file.