Web プロジェクトの変換の編集

作成した変換画面を参照するには、「ZIETrans プロジェクト」ビューで、「Web コンテンツ/変換」フォルダーを展開します。Rational® SDP に組み込まれている Rich Page Editor を使用して変換を編集するには、変換の名前をダブルクリックします。使用可能なその他のエディターを参照するには、変換画面の名前を右クリックして、「オープン先を指定」を選択します。メニュー・バーの「ヘルプ」> 「ヘルプ目次」を選択して Rich Page Editor を検索することにより、Rich Page Editor に関する Rational SDP 資料を参照してください。

以下の制限事項は、変換の編集に適用されます。
注: ある ZIETrans プロジェクトから別のプロジェクトに変換をコピーした場合、その変換に関連付けられている画面キャプチャー・ファイルはコピーされません。コピーされた変換は、関連画面キャプチャー・ファイルがなくても実行時に機能します。ただし、関連画面キャプチャー・ファイルがないと、コピーされた変換を ZIETrans Toolkit でプレビューすることはできません。

コピーした変換をプレビューするには、関連付けられている画面キャプチャー・ファイルを「画面キャプチャー」フォルダーで選択して、これをコピーする必要があります。画面キャプチャー・ファイルをコピーしたら、前の画面に戻り、「変換」フォルダーからコピーした変換を選択して、変換を開きます。「デザイン」タブに移動して、ウィンドウ内の任意の場所で右クリックします。「ZIETrans ツール」>「ホスト・コンポーネントを編集」を選択します。ウィザードが表示されたら、ドロップダウン・メニューから画面を選択して、「完了」をクリックします。

変換を編集する際、「プロパティー」ビューを使用すると、ZIETrans コンポーネントやその他のコントロール (ボタン、イメージ、リンクなど) のプロパティーを変更できます。「プロパティー」ビューは、変換エディターの下のほうにあります。「プロパティー」ビューは、ZIETrans メニューから「ウィンドウ」>「ビューの表示」>「プロパティー」を選択することでもアクセスできます。

また、「パレット」ビューを使用して、ZIETrans コンポーネントを変換に追加することもできます。ドロップダウン・メニューからコンポーネントを選択して、それを変換にドラッグできます。また、「パレット」には、編集を容易にするためにさまざまなタグ (HTML、フォーム・タグ、JSP など) が含まれています。このビューは、メニュー・バーから 「ウィンドウ (Window)」>「ビューの表示 (Show View)」>「パレット (Palette)」を選択することでも起動できます。
注: カスタム・コンポーネント、ENPTUI、およびライト・ペン・コンポーネントは、Rich Page Editor「パレット」ビューの「ZIETrans コンポーネント」セクションには表示されません。これらのコンポーネントを使用可能にすると、Rational SDP のメニュー・バーで、「ZIETrans ツール」>「ホスト・コンポーネントを挿入」をクリックすることにより、これらのコンポーネントにアクセスできます。

以下のセクションでは、Rich Page Editor の各タブについて説明します。